SAP Knowledge Base Article - Public

3296884 - Facebook Connect with Channel Opening a Blank/Empty Page

Symptom

After configuring a Facebook channel, when clicking on Connect with Channel, the Facebook site is opening with blank/empty page.

Environment

 SAP Cloud for Customer

Reproducing the Issue

  1. Navigate to Administrator work center.
  2. Navigate to Service and Social work center view.
  3. Click Social Media Channels.
  4. Click New.
  5. Fill in all mandatory details.
  6. Click Connect with Channel.
  7. See the new page opens up, a blank empty page is opened.

Cause

The described issue can be caused due to 3 different root causes:

-Missing OAuth redirect URIs configuration.
-Pop-up / browser blocker or cache.
-Facebook API Issue/instability.

Resolution

 1. Missing OAuth redirect URIs configuration

You can validate it by following the below steps:

1. Go to your Apps athttps://apps.facebook.com/
2. Click the link "Manage Apps" on the left side
3. Find your Apps and you should be able to find "Facebook Login" on the left side
4. Select Settings
5. On * OAuth redirect URIs" field, addhttps://myXXXXXX.crm.ondemand.com/sap/byd/oauth/facebook/ (XXXXXX is your tenant URL)
6. Please ensure that you logout from Facebook and start the browser before authenticating the channel.

It is important to note that all the customer apps are required to be reviewed by Facebook before they can be used. Customers are responsible for the continuity of apps and its contract with Facebook.

Please refer to the link below from Facebook for this process:
https://developers.facebook.com/docs/apps/review

In the Cloud for Service – Facebook integration, you would have to request for the following permissions – manage_pages, read_page_mailboxes, publish_pages, pages_messaging for your Facebook *

SAP does not request for any of the permissions-“user_friends”, “user_link”, “user_gender”, “user_age_range” that are mentioned in their alert. However, it is advisable to submit your request and get the approval.

In addition, refer to below link for more information.
https://blogs.sap.com/2018/05/25/cloud-for-service-social-channels-submit-your-facebook-apps-for-review/

2. Pop-up / browser blocker or cache

Please make sure to deactivate any pop-up add-ins from your browser, it is also advisable to clear your browser cache (setting it to all date)

3. Facebook API Issue:

The page being loaded is from the Facebook API (if you copy the URL you will see something like https://www.facebook.com/login.php?skip_api_login ). When all the previous configuration and suggestions were done and the issue persists, you will need to get in touch with Facebook support team, asking why the URL being called does load a blank page.

Keywords

Not Working; Integration; Channel; Social; , KBA , LOD-CRM-SRP , Service Request Processing , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions