SAP Knowledge Base Article - Public

3296889 - When using a CDS view to retrieve the Auto renewal field the data is shown as "No Selection, can be changed ".

Symptom

When using a CDS view to retrieve the Auto renewal field the data is shown as "No Selection, can be changed ".

Environment

SAP S/4HANA Cloud 

Cause

The Autorenewal data is determined from the settings maintained within the material itself of the selected line item.

Resolution

  1. Open the Service Contract.
  2. Navigate to the line items of the contract.
  3. After selecting an item you will be rerouted to the Manage Product Master Fiori App.
  4. Go to the Sales Tab.
  5. Inspect the settings maintained for Contract Auto Renewal Indicator.
    These settings can be:
    No Selection, can be changed.
    2 Not relevant for Autorenewal
    1 Set to Yes, can be changed

Keywords

service contract, auto renewal, crm, service , service order, S/4HANA Cloud, SAP S/4HANA Cloud, No Selection, can be changed, Not relevant for Auto Renewal, Set to Yes, can be changed  , KBA , CRM-S4-REP-CDS , S4CRM: Reporting Data Service , Problem

Product

SAP S/4HANA Cloud 2208