SAP Knowledge Base Article - Public

3297537 - Picklist field is blank post-instance refresh - Recruiting Management

Symptom

After performing an instance refresh, some picklist field (e.g., State field) defined in the template is showing blank in UI, while it should have a value.

Environment

SAP SuccessFactors Recruiting Management

Cause

Picklist cache corruption after instance refresh.

Resolution

In order to have some recruiting pages loading faster, behind the scenes we use a cache to store picklist information. Every time you load an application detail page, for example, the system retrieves the picklist labels from cache and not directly from the database. Furthermore, every time a change happens in the picklist information, picklist center, the cache is refreshed.

Hence, you can force the picklist cache to be refreshed by following the steps mentioned in this KBA: 3041749 - Picklist is Showing Duplicated Values or Option ID - Recruiting Management

Keywords

refresh, cache, corruption, application, instance , KBA , LOD-SF-RCM-SYS , System Performance, Usability, Errors, Security , Problem

Product

SAP SuccessFactors Recruiting all versions