Symptom
When trying to generate summary in tickets, you are receiving an error 'XML Transformation Failed'.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Service workcenter.
- Go to the Tickets view.
- Open the ticket 123(where 123 represents the ticket ID).
- Click the Summary button.
- Select the Add Summary option.
- Select the relevant template from the drop down.
- Click the OK button.
Following error message is triggered: ‘XML transformation failed’.
Cause
The fields have a character limit of 255 characters and this limit has been exceeded. This can happen even when there is a Survey linked to the Ticket that has a question with more than 255 characters.
Resolution
You will need to reduce the character length. For example, you need to restrict the Survey question length to 255 characters as this is a system limitation for generating summary from Ticket.
See Also
Keywords
Ticket, Generate summary, characters, XML Transformation Failed, 255, limit, Survey. , KBA , LOD-CRM-SRP-OPM , Output Management , LOD-CRM-SRP , Service Request Processing , Problem