Symptom
- Users claims that the hyperlinks within the body of an e-mail is lost when viewed from the Tickets -> Interactions view
- The same Link/URL works when the e-mail is opened in clients like MS Outlook
Environment
- SAP Service Cloud
- SAP Sales Cloud
- SAP Cloud for Customers
- Microsoft Outlook
Reproducing the Issue
- An e-mail with content which has hyperlinks is sent to the corresponding e-mail channel
- In C4C, a ticket is created
- The agent opens the ticket and navigates to "Interactions" tab
- In the e-mail body, what was previously a hyperlink does not work anymore
Cause
- 3rd party issue
- The system is working as designed
- C4C will display the content based on the content type sent in the MIME by the originating e-mail server
- If the "Content-Type: text/plain; charset="us-ascii"" is used, then C4C will use simple text without any formatting
- If the "Content-Type: text/html; charset="utf-8"" is used, then C4C should maintain the same formatting and the hyperlinks should work
Resolution
- Ensure the originating e-mail provider/server include the correct MIME information to support rich text content. For example, Content-Type: text/html
- Users can also view the original e-mail per KBA 2236026 (View Original Content)
See Also
2236026 - How To Check e-mail Content When Formatting And Inline Images Are Not Shown In The Incoming E-Mails
Keywords
Safe Links embedded in the body of an e-mail are not hyperlinked, , KBA , LOD-CRM-SRP , Service Request Processing , LOD-CRM-SC-EML , Email , Problem
Product
SAP Cloud for Customer core applications 2211