Symptom
The Task Chain status is "Running" however there is no progress in the runs when checking the "Run Details".
The Task chain stops/locks in hanging state.
Environment
SAP Datasphere
Cause
Under investigation.
Resolution
The solution is to manually stop the task(s), which block(s) all other task chains in the same tenant.
- Find out the possible (the earliest started one) candidate to stop, either using SQL or in DWC;
- In DWC, select System Monitor->Logs, then set Filter "Status" = "RUNNING" and sort "Start Time" by "Ascending"
- In SQL console, query "DWC_GLOBAL"."TASK_LOGS" with where condition "STATUS" = "RUNNING" and order by START_TIME ASC;
- To only stop one task might not solve the issue, in such case, better wait for 30 ~ 60 minutes to stop the next earliest of the remaining running tasks.
- If the above provided solution does not solve the issue, it reoccurs or you cannot stop the tasks, we recommend you to open a support ticket.
Please follow KBA 2854764 - Guidelines for DWC Incidents when opening support ticket.
Keywords
task chain, lock, schedule, run, stop, hang , KBA , DS-DI-SCH , Scheduling and Task Chains , DS-DI-VIW , View Persistency and Runtime , DS-MD-VIW , Views , Problem
Product
SAP Datasphere all versions