Symptom
Error "Playbook cannot be activated, Define an activity/action" is thrown when you are trying to define a Rule in Playbook.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Activity Planner Workcenter.
- Go to Playbooks view.
- Create a new Playbook.
- Go to Define Rule tab.
- Fill in manually the relevant information.
- Error appears.
Cause
In order to save and activate a playbook following conditions should be met
- At least one action/activity in Step 1;
- At least one rule in Step 2 OR at least one Account/Sales Org filter in Step 3.
If above conditions are not met, the Playbook will be saved in Draft/In Preparation status, and cannot be activated. The mentioned error is also thrown to this effect.
Resolution
In order to solve the error message and to be able to activate the Playbook, you need to make sure that the above conditions are met.
Keywords
Playbook , Error Message , Error , Active , KBA , LOD-CRM-SBS-GS , Guided Selling and Playbook , How To
SAP Knowledge Base Article - Public