SAP Knowledge Base Article - Public

3300248 - "Playbook cannot be activated, Define an activity/action"

Symptom

 Error "Playbook cannot be activated, Define an activity/action" is thrown when you are trying to define a Rule in Playbook.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to Activity Planner Workcenter.
  2. Go to Playbooks view.
  3. Create a new Playbook.
  4. Go to Define Rule tab.
  5. Fill in manually the relevant information.
  6. Error appears.

Cause

In order to save and activate a playbook following conditions should be met

  1. At least one action/activity in Step 1;
  2. At least one rule in Step 2 OR at least one Account/Sales Org filter in Step 3. 

If above conditions are not met, the Playbook will be saved in Draft/In Preparation status, and cannot be activated. The mentioned error is also thrown to this effect.

Resolution

In order to solve the error message and to be able to activate the Playbook, you need to make sure that the above conditions are met.

Keywords

Playbook , Error Message , Error , Active , KBA , LOD-CRM-SBS-GS , Guided Selling and Playbook , How To

Product

SAP Cloud for Customer core applications all versions