Symptom
While updating JobApplicationQuestionResponse via oDATA API for a Free Text field the number of characters is validated 1 less than the configured maximum character limit in the UI.
Environment
SAP SuccessFactors Recruiting Management (RCM)
Reproducing the Issue
Set pre-screening questions in a requisition of type free text with 20 maximum character limit and pass below request via Postman
Update JobApplicationQuestionResponse via Postman using oDATA API query as below:
Request:
{
"__metadata": {
"type": "SFOData.JobApplication"
},
"candidateId": "6161",
"jobReqId": "3096",
"appLocale": "en_US",
"firstName": "Test",
"lastName": "Candidate",
"jobApplicationQuestionResponse": [
{
"__metadata": {
"type": "SFOData.JobApplicationQuestionResponse"
},
"order": "1",
"answer": "12345678901234567890"
},
{
"__metadata": {
"type": "SFOData.JobApplicationQuestionResponse"
},
"order": "2",
"answer": "1234567890"
}
]
}
Below error is received: [COE0019]Please enter an answer that is 20 characters or less for question 'Describe your experience in presenting in front of customers.' (order=1)
Cause
API validates 1 less character set in the Answer range for a Free Text type pre-screening question.
Resolution
When updating Free Text field via oDATA API it is recommended to pass 1 less character than the set maximum character limit for the pre-screening question.
Note: ODATA API only supported plain text screening questions. Applications submitted via ODATA with required screening questions, will not recognize the screening answer response if the Question contains any type of HTML or Page breaks etc
Keywords
JobApplicationQuestionResponse, pre-screening question, character limit, oDATA API, free text, plain text, HTML, page break. , KBA , LOD-SF-RCM-API , Webservices & APIs , How To