Symptom
When you are updating Collaboration tab of Accounts using Migration tool, it throws an error message
Cannot create duplicate entries in Collaboration view.
Or you are trying to use the Mass Data Maintenance, where after executing the Data Import there is no error message, however the data is not updated in the Account Management work center.
Environment
SAP Business ByDesign.
Reproducing the Issue
- Go to Business Configuration and select the Overview view.
- Search and open the activity Migration of Customer.
- Click link to Migrate Customers using the Migration Tool.
- Upload the file and use " Enhance Existing Record" Mode.
- Select Execute Migration, then Execute Migration Step by Step.
- Error message appears "Cannot create duplicate entries in Collaboration view".
Cause
The customer collaboration data doesn't support in migration tool, neither via Mass Data Maintenance.
Resolution
The following payload will allow you to add multiple e-mail lines to an account in one go:
<n0:CustomerBundleMaintainRequest_sync_V1 xmlns:n0=" http://sap.com/xi/SAPGlobal20/Global ">
<BasicMessageHeader/>
<Customer actionCode="04">
<InternalID>XX</InternalID> (Here XX refers Internal ID)
<CommunicationArrangementMultiChannel actionCode="04" communicationChannelListCompleteTransmissionIndicator="true">
<CompoundServiceInterfaceCode>D1</CompoundServiceInterfaceCode> (Here D1 refers to Compound Service Interface Code)
<EnabledIndicator>true</EnabledIndicator>
<CommunicationChannel communicationEmailListCompleteTransmissionIndicator="true">
<CommunicationMediumTypeCode>INT</CommunicationMediumTypeCode> (Here INT represents the Communication Code)
<CommunicationEmail>
<EmailURI>XXX, XXX1</EmailURI> (Here XXX and XXX1 are the E-mail ID)
<RecipientFieldTypeCode>CC</RecipientFieldTypeCode> (Here CC represents the Recipient Field Type Code)
</CommunicationEmail>
<CommunicationEmail>
<EmailURI>XXX1</EmailURI>
<RecipientFieldTypeCode>CC</RecipientFieldTypeCode>
</CommunicationEmail>
</CommunicationChannel>
</CommunicationArrangementMultiChannel>
</Customer>
</n0:CustomerBundleMaintainRequest_sync_V1>
As a workaround you can use the web service that is ManageCustomerIn. Here you can enhance the collaboration data via the element "CommunicationArrangementMC" in case of multi channels
Keywords
Customer Collaboration, CommunicationArrangement, ManageCustomerIn, Migration of Customer, Mass Data Maintenance, Customers. , KBA , customer collaboration , communicationarrangementmc , managecustomerin , migration of customer , SRD-CRM-ACC , Account Management , SRD-MD-BP , Business Partner , Problem