Symptom
- When the user is changing the email address in current employment, the email address is changed in the past employment as well. (vice versa)
- Unable to save two different email address for two different employments for a user.
Environment
- SAP SuccessFactors Employee Central - Personal Information
Reproducing the Issue
- Navigate to contact information of current employment of a user.
- Change the email address to a new email address --> save.
- Navigate to past employment of the user and you will see that the new email address is reflecting in the contact information of the past employment as well.
Cause
Contact information is person-based, not employment based.
Resolution
This is an expected behavior. Contact information is person-based, so it will be shared among all employments.
It is not possible to keep different contact information for each employment.
This behavior is the same for all person based sections, such as address information, personal information and so on.
Note: When the employee is rehired through rehire inactive employee and a new email address is added while hiring then the same email address will be reflecting in the past employment as well.
See Also
3272025 - Error when adding email address with a type that already exists - Employee Central
Keywords
email address, contact information, current employment, past employment, old email, new email, person-based contact information, email information being updated in different employments, assignments, address, previous profile, rehire, both profiles, emergency contact, global info, work permit, phone info , KBA , LOD-SF-EC-PER-EML , Email Info - Config, Rules, RBP, UI , LOD-SF-EC , Employee Central , How To