Symptom
This document is to provide prerequistes when requesting tenant refresh from a source tenant which is SSO configured
Possible Scenarios,
Scenario 1:
In the Production (Source tenant), tenant is configured for SSO
In the Test (Target tenant), tenant is configuration of User Name and Credentials
Scenario 2:
Both Source and Target are SSO configured
Environment
SAP Business byDesign
SAP Cloud for Customer
Cause
SSO Configuration
- After Tenant Refresh, tenant ID/URL of the target tenant is constant, or in other words, it stays the same after the tenant copy.
- Nevertheless, it will be required to configure SSO in the target tenant.
- Tenant refresh is nothing but create new fresh tenant with the whichever Data Source you have selected and replacing the URL, so physically the connection is broken so SSO configuration needs to be done from the scratch.
Resolution
Before raising refresh request make sure that there is at least 1 key user in production system (source tenant)
1. Who can login with password. So the same user login into the target tenant to re-configure the SSO configuration.
2. With correct email configured if needed to set password via 'Forgot Password'
Note:
- If you don't know how to change the User login typ from SSO to User ID and Password, you can follow the steps: Application User and Management work center -> Business User -> Select the Key/Admin User -> Click on Edit and edit the Security Policy and change it to either "Default Password Policy for Business Users - Version 2" or one which you have defined to login with the User ID and password.
Once you have done the changes to the Security policy for the Key/Admin User, you can raise the tenant refresh request, so that once the refresh is done, you have the User ID and Password which you can use to login without any issues.
See Also
To know more about Tenant Refresh, refer to the Help Center Documentation
2340655 - How to Request Tenant Refresh in SAP Business ByDesign
Keywords
sso, tenant refresh, forgot password, login , KBA , sso, tenant refresh, forgot password, lo , SRD-CC-IAM , Identity & Access Management , SRD-CC-SEC , Security , Problem