Symptom
- After resetting a user password, the user is unable to access SuccessFactors instance.
- You are a SuccessFactors administrator of a tenant where user credentials are managed bu SuccessFactors (Not via IAS or a corporate Identity IdP provider such as MS Azure) and you have requested to Reset individual user password and later attempted to login from your side but the new password is not working
Environment
SAP SuccessFactors HXM Suite
Reproducing the Issue
- Go to Resetting User Password
- Select the user you want to change password
- Set new password
- Click on "Reset User Password"
User is unable to log in using the password created.
Cause
Such use case would confirm that the login name is empty for the user. You can confirm that by going to Admin Center > Manage Login Accounts.
Resolution
Verify in Manage Login Accounts if this user has 2 employments and 1 login name (any user is assigned only one login name, regardless of how many employments they have).
If you wish to reset password for the other employment, you must first change the login name linked with it:
- Navigate to the Manage Login Accounts;
- Click "Change login account" to switch login name to the desired other employment;
- Proceed to reset password for the other employment in Reset User Password tool;
- Note: This tool is designed to reset passwords for login names only.
Check if there are orphan accounts in the system for this user:
- Navigate to Check Tool;
- Click on User Account Management;
- Check There are no orphan accounts in the system (OrphanAccountCheckExecutor);
- Run the quick fix for the impacted user.
- Proceed to reset password for the other employment in Reset User Password tool.
If the above does not apply to your use case, please create a support incident under the component LOD-SF-PLT-MNG, as support team will have to engage engineering team to correct the affected user information in the backend.
Keywords
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