SAP Knowledge Base Article - Public

3301384 - No users found in People Picker dialog box for Service Entry Sheets

Symptom

In app Manage Workflows for Service Entry Sheet, no users are found while adding the approver recipients.

Environment

SAP S/4HANA Cloud Public Edition

Reproducing the Issue

  1. Open the Manage Workflows for Service Entry Sheet App.
  2. Click the Create button.
  3. In the Steps, click the Create button to add a new workflow step.
  4. Choose Add to simulate the creation of a new workflow entry.
  5. In the Header, select Release of Service entry Sheet in the Step Type field.
  6. Under Recipients, select User in the Assignment By field.
  7. Click the People Picker button (F4 Help) in the User field.
  8. In the dialog box, click the Go button.

Cause

Missing Authorization.

Resolution

Users will be found by People Picker, if the following prerequisites are fulfilled:

  1. User must have authorization for My Inbox (SAP_BR_MANAGER)
  2. User must have authorization to edit SES (SAP_BR_PURCHASER)
  3. User has a valid work agreement in Manage Workforce app.

Keywords

no users found, people picker, F4Help empty, No approver found, users, roles, authorization, workflow app, ses, service entry sheet approver, empty search help, S4HC, MM-PUR-SVC-SES, S4_1C, X4BC, S4_PC , KBA , MM-PUR-SVC-SES , Service Entry Sheet for Service Procurement , Problem

Product

SAP S/4HANA Cloud Public Edition all versions ; SAP S/4HANA Cloud all versions