Symptom
You have created an Overt-the-Counter (OTC) transaction and selected payment method as credit card. However, you either do not find the option to add a new credit card or the authorization fails.
Environment
SAP Business ByDesign.
Reproducing the Issue
- Go to Over-the-Counter Sales work center.
- Go to Over-the-Counter Sales view.
- Open the respective transaction.
- In the General tab, under Payment section, select credit card.
- Click Check Authorization.
You either see no credit card available for selection or when checking the authorization, it fails with the following error: 'Technical error in payment authorization; report an incident'
Cause
There are a few reasons for the credit card authorization to fail. The most common one happens due to missing/incomplete integration with a payment service provider (Computop or Digital Payments). Since the system does not have the complete master data yet it cannot establish a connection and communicate the authorization details.
Overall, you can check if the master data is complete by checking if the Register with Computop or Register with Digital Payments button is enabled in the customer account master data, as follows:
- Go to Receivables work center.
- Go to Customer Accounts view.
- Open the master data of the relevant customer account.
- Go to Financial Data -> Bank Data.
- Under Credit Card section, check weather the Register with Computop or Register with Digital Payments are available and working.
This is a good indication that the master data is complete.
Via these buttons, you're also able to register a new credit card to be used in the OTC transaction.
Resolution
Therefore, you need to revise the credit card integration setup. You can refer to help document Customer Payments by Credit Card.
For the Over-the-Counter scenario, if you choose the payment method as Credit Card, then the system understands that you are using SAP Business ByDesign to initiate the credit card transactions (register the card, authorization and settlement) from within ByD. For that to happen, an integration with a payment service provider must exist.
If you have already an agreement with a payment service provided to manage credit card transactions and this is being done from outside ByD, then you can select the payment method as external payment for the over-the-counter transaction. Once it gets released, an Incoming External Payment entry is automatically created in the payment monitor.
See Also
Keywords
Over-the-Counter. Credit Card. Authorization. , KBA , SRD-FIN-CLM , Cash and Liquity Managment , How To