SAP Knowledge Base Article - Public

3301498 - "Temporary ID" and "is Temporary" fields are not visible under National ID portlet - Employee Central

Symptom

When navigating to National ID portlet, "Temporary ID" and "is Temporary" fields are not visible even if they are correctly configured as per KBA 2755154 - How To Enable Temporary National ID Fields.

Environment

SAP SuccessFactors Employee Central

Reproducing the Issue

  1. Enable "Temporary ID" and "is Temporary" fields as per KBA 2755154;
  2. Go to Employee Profile;
  3. Scroll down to National ID portlet;
  4. See the fields "Temporary ID" and "is Temporary" are not available.

Cause

Permissions of these two fields are not enabled.

Resolution

  1. Go to Manage Permission Roles;
  2. Select a Permission Role which the user is inserted;
  3. Click on "Permission...";
  4. Go to Employee Data;
  5. Check the boxes "Is Temporary" and "Temporary ID";
  6. Save.

See Also

2755154 - How To Enable Temporary National ID Fields

Keywords

national id, national id portlet, temporary id, is temporary, temporary id not visible, is temporary not visible, rbp, role based permissions, employee data , KBA , LOD-SF-EC-PER-NAT , National ID - Config, Rules, RBP, UI , LOD-SF-EC-RBP , Roles & Permissions (EC Core only) , How To

Product

SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM Suite all versions