Symptom
When navigating to National ID portlet, "Temporary ID" and "is Temporary" fields are not visible even if they are correctly configured as per KBA 2755154 - How To Enable Temporary National ID Fields.
Environment
SAP SuccessFactors Employee Central
Reproducing the Issue
- Enable "Temporary ID" and "is Temporary" fields as per KBA 2755154;
- Go to Employee Profile;
- Scroll down to National ID portlet;
- See the fields "Temporary ID" and "is Temporary" are not available.
Cause
Permissions of these two fields are not enabled.
Resolution
- Go to Manage Permission Roles;
- Select a Permission Role which the user is inserted;
- Click on "Permission...";
- Go to Employee Data;
- Check the boxes "Is Temporary" and "Temporary ID";
- Save.
See Also
Keywords
national id, national id portlet, temporary id, is temporary, temporary id not visible, is temporary not visible, rbp, role based permissions, employee data , KBA , LOD-SF-EC-PER-NAT , National ID - Config, Rules, RBP, UI , LOD-SF-EC-RBP , Roles & Permissions (EC Core only) , How To
Product
SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM Suite all versions