Symptom
You have uploaded and activated new Rules (for example, Ticket Routing Rules) and note the below message:
"Please close the screen after activation to unlock the process for business users."
When testing the changes you notice that the performance has been severely impacted. The issue usually resolves itself after a few hours.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Open Ticket Routing Rules in UI
- Upload Excel file
- Save
- Activate Rules
- Navigate to Service > Tickets
- Click New
Cause
When a particular user is editing/saving/activating the rules (even just having the screen open), a lock is acquired on the object. This locking is to ensure data consistency.
Hence if the rule screen remains open after first time change of the rules and simultaneously in another screen, a user is trying to create a new ticket, the lock is already acquired. The generated rule class does not exist at this point, so the code evaluation happens in "interpretation" mode.
Processing the activated rules in "interpretation" mode is expected behaviour to ensure the class generation is not corrupted or some other user does not change the rules at the same time.
Resolution
The user should close the rule screen after updating and activating the rules before the new rules are evaluated for the first time:
- Open Ticket Routing Rules in UI (now already in edit mode)
- Upload Excel file (or on-screen editing)
- Save
- Activate Rules
- Close Ticket Routing Rules
- Navigate to Service > Tickets
- Click New
During first time rule evaluation, the rule class will be generated and each subsequent time, the generated class will be used for evaluation.
Keywords
BRF, Decision table, Territory Rules, interpretation mode , KBA , LOD-CRM-BRF , C4C BRF Configuration , Problem