Symptom
In the EWA report for the TREX system, the following warning is reported in the section "Quality of Service Data in Solution Manager Diagnostics - BW":
No performance data is returned from BW InfoCube. Infocube: 0SMD_MPEH , metric type: TREX SEARCHPERF , metric name: Total Search Count(n) used in section 'TREX System Data for <SID of TREX system>' |
In the section "TREX System Data for <SID of TREX system>", data for metrics "average search count", "Average Search Time", "Average Index Count" and "Average Index Time" are filled.
Environment
- SAP Solution Manager 7.20
- All TREX versions
Cause
The TREX metrics are collected while calling directly the sapstartsrv via command:
sapcontrol -host localhost -nr 00 -function GetAlertTree
(nr = Instance-Number of TREX)
The output has changed in 2015 already and “Indexing Count (n)” and Search Count(n) are no longer delivered from GetAlertTree.
Therefore the ‘Total…’ metrics are not available and the “metrics /request” cannot be calculated.
Resolution
The message "No performance data is returned from BW InfoCube. Infocube: 0SMD_MPEH , metric type: TREX SEARCHPERF , metric name: Total Search Count(n) used in section 'TREX System Data for <SID of TREX system>'" can be ignored as this data is not available for TREX.
In EWA report, only 'Average' data will be used in section "TREX System Data for <SID of TREX>".
See Also
2655586 - Unable to Activate TREX Checks in * using Solution Manager 7.2
1978360 - EarlyWatch Alert For TREX
2087027 - CCDB extractor cannot find TREX configuration files
Keywords
KBA , SV-SMG-DIA-APP-WA , Workload Analysis , Problem