SAP Knowledge Base Article - Public

3303069 - Phone And Mobile Field Are Not Showing As Hyperlink For Contacts

Symptom

 "Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

You are using the C4C app and notice in the Contacts details screen, the Phone and Mobile numbers are not clickable.

Environment

SAP Cloud For Customer

Reproducing the Issue

  1. Open C4C tenant using App.
  2. Go to Customers Workcenter -> Contacts View -> Open any Contact.
  3. You have a Mobile/Phone Number maintained but it is not showing as a link.

Cause

In Adaptation Mode, There is two of each fields. One field will show the number as text and the other will show the number as a link.

Resolution

  1. Go to Contacts Screen -> Open Adaptation Mode.
  2. Go to Header fields.
  3. Depersonalize or Hide the First Phone and Mobile fields and keep the second fields visible.

Keywords

Link, Hyperlink, Click, Clickable, Call, Number, Contact, Phone, Mobile, Dial, Details, C4C, App, Application, Sales, Cloud, Adapt, Adaptation, Detail, View , KBA , AP-RC-UIF-FLX , Page Layout & Key User Configuration , LOD-CRM-CON , Contact , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions