SAP Knowledge Base Article - Public

3303712 - 'No Data' is shown for 'View Actions' in Time Alerts

Symptom

'No data' is displayed when clicking on 'View Actions' as below

As a result, it is not possible to navigate to time sheet or directly carry out correction from Time Alerts.

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental." 

Environment

  • SuccessFactors Employee Central - Time Sheet
  • SuccessFactors Time Tracking

Reproducing the Issue

  1. Go to 'Time Alerts' tab for an employee from either 'Administer Time' or from 'Admin Alerts' tool. 
  2. Click on the 'View Actions', attempting to navigate to time sheet or correct the alert.
  3. No action is available. 

Cause

The "Time Management Alert" object has been secured and the user misses Edit permission on Time Management Alert. 

Resolution

Please make sure the Edit permission of Time Management Alert object is granted to the employee.

If this symptom happens with Time Valuation Alert or Time Collector Alert, then Edit permission is needed for Time Valuation Alert and Time Collector Alert respectively.

View permission alone is not enough.

See Also

Keywords

alert, navigate, tms, ttr, recalculate, import, admin, rbp, role, time, valuation, collector, generate, management, administer time, time alerts, recalculation alert , KBA , LOD-SF-EC-TMS , Time Sheet , LOD-SF-TTR , Time Tracking , Problem

Product

SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors Time Tracking all versions