Symptom
Issue in updating a Sales Quotes status from Open to Completed and Progress from Pending to Won.
Environment
SAP Cloud for Customer
ERP
Reproducing the Issue
- Navigate to the Sales Work centre > Sales Quotes.
- Search for the affected quote > actions > click on copy.
- It will create a new quote.
- Set the status from open to completed and from pending to won.
- After saving the quote a technical user responsible for integration is seen reverting the statuses back to open and pending which is not expected.
Cause
When the message is replicated to the ERP, the progress status will change to Pending and the status to Open. This is done that way to keep ERP and Cloud for Customer in sync as much as possible. To change the C4C quote to Won/Completed and open in ERP is not possible. To have the quote to be set as won it has to have at least one referenced sales order (C4C or ERP). You can only manually set a quote as won if it is not replicated to the external system.
Resolution
If it is a bidirectional quote, this is the expected system behavior. Once a Sales Order is referenced correctly to the quote, the won action should be able to be applied.
Keywords
ERP, quote, sales, cloud for customer, integration , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , Problem