SAP Knowledge Base Article - Public

3304206 - Missing Approval Email Notification from CPQ setup

Symptom

One or multiple Email Notifications are not being sent to the users.

Environment

SAP SALES CLOUD CPQ

Reproducing the Issue

  1. Trigger the email notification from the quote as per the workflow setup;
  2. Check the developer tool logs, Filter logs by the Logger and Title to Email Notification;
  3. Find the trace which starts with Processing Notification and ends with Successfully Processed : False. This can be searched by filter the description by Processing Notification or False keyword.

Cause

Inactive user is present in the Approver Rule->Selected Approvers.

Resolution

  1. Go to Setup;
  2. In Workflow/Approvals enter in Approver Rule;
  3. Enter in Selected Approvers;
  4. Check the Selected Approvers list if there is any inactive user, if yes remove the user from the list.

See Also

In CPQ-2305 functionality will be enhanced, If the inactive user is added in the Approver Rule -> Selected Approvers list, user will be provided with prompt that Inactive user is added. 

Keywords

CPQ, Email Notification, Approval Rule, Email, Inactive, User , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , Problem

Product

SAP CPQ all versions