Symptom
You are trying to send quotes for approval, and the approvers are not receiving email notifications.
When we check in CPQ logs, we can see erroneous logs stating "Workflow Notification failed.", "Notification to Approver was not sent successfully."
Environment
SAP SALES CLOUD CPQ
Reproducing the Issue
- Trigger the email notification from the quote as per the workflow setup
- Check the developer tool logs, Filter logs by the Logger and Title to Email Notification
- Find the trace which starts with Processing Notification and ends with Successfully Processed : False.
This can be searched by filter the description by Processing Notification or False keyword.
Cause
- Inactive user is present in the Selected Approvers, under Approver Rule.
- Another reason is if the Approver has an invalid email ID.
Resolution
- Go to Setup
- In Workflow/Approvals, go to the Approver Rule
- Go to Selected Approvers
- Check the Selected Approvers list if there is any inactive user or any user that has a wrong email ID, if yes remove the user from the list.
Keywords
Email Notification, Approval Rule, Email, Inactive User, Workflow Notification failed, Notification to Approver was not sent successfully , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , Problem
Product
SAP CPQ all versions