SAP Knowledge Base Article - Public

3304274 - Status of Contact changing From Obsolete back to Active during replication.

Symptom

In C4C when Customer Contact status field is set to Obsolete by a User the status is automatically changing back to Active.

Environment

SAP Cloud For Customer.

Reproducing the Issue

  1. Open your Cloud For Customer tenant.
  2. Navigate to the Customer workcenter and select a Contact.
  3. Change any Contact status from Active to Obsolete.
  4. Wait a few minutes (10 mins max) and open the contact again or refresh.
  5. Notice that the status has changed back to Active.

Cause

Status is being changed by technical user XXXXX from Obsolete to Active.

Resolution

  • You are not maintaining a relevant Communication Arrangement Filter.
  • To add the Communication Arrangement filter, go to the Administrator work center.
  • Under General Settings select Communication Arrangement filter.
  • Once opened click on Add Row on the right of the header bar, in the Communication Partner field select Technical user XXXXX in the communication scenario field add the scenario Business partner replication from SAP Business Suite.
  • Add the row to the filter "Don't reactivate Obsolete Contacts".
  • Save and close.

Keywords

Status, Obsolete, Active, Don't reactivate Obsolete Contacts, Communication Arrangement Filter, Communication Arrangement, Contact, Customer, Account, Technical User , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions