Symptom
You are not able to create new Sales Orders on the Opportunity due to the button "New" that is grayed out.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Navigate to Sales Work Center.
- Go to Opportunities Work Center View.
- Open Opportunity 123 (where 123 is the Opportunity ID).
- Go to Sales Documents facet.
- See the button "New" is grayed out for Sales Order.
Cause
There is a Product on the Opportunity that is blocked. Thus, the Opportunity becomes inconsistent.
See the Error Message "Product &1 not valid; it is blocked" (where &1 is the Product ID).
Resolution
If you want to create a follow-up Sales Order for non-blocked products, please follow the steps below:
- Navigate to Business Configuration Work Center.
- Go to Overview Work Center View.
- Open Opportunities Activity.
- Go to Message Severity Configuration.
- Find the message "Product &1 not valid; it is blocked".
- Change the Severity from "4-Error" to "3-Warning".
Please note: A dummy change on the Opportunity is necessary to make the document consistent again.
Keywords
Product &1 not valid; it is blocked; New; Grayed out; Sales Order; Sales; Order; Opportunity; C4C; Product; Blocked; Deactivated; , KBA , LOD-LE-OPP , Opportunity processing , LOD-LE-CQP , Customer Quote Processing , How To