SAP Knowledge Base Article - Public

3304400 - Unable to Create Sales Order from an Opportunity that Includes Blocked Products

Symptom

You are not able to create new Sales Orders on the Opportunity due to the button "New" that is grayed out.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Navigate to Sales Work Center.
  2. Go to Opportunities Work Center View.
  3. Open Opportunity 123 (where 123 is the Opportunity ID).
  4. Go to Sales Documents facet.
  5. See the button "New" is grayed out for Sales Order.

Cause

There is a Product on the Opportunity that is blocked. Thus, the Opportunity becomes inconsistent.

See the Error Message "Product &1 not valid; it is blocked" (where &1 is the Product ID).

Resolution

If you want to create a follow-up Sales Order for non-blocked products, please follow the steps below:

  1. Navigate to Business Configuration Work Center.
  2. Go to Overview Work Center View.
  3. Open Opportunities Activity.
  4. Go to Message Severity Configuration.
  5. Find the message "Product &1 not valid; it is blocked".
  6. Change the Severity from "4-Error" to "3-Warning".

Please note: A dummy change on the Opportunity is necessary to make the document consistent again.

Keywords

Product &1 not valid; it is blocked; New; Grayed out; Sales Order; Sales; Order; Opportunity; C4C; Product; Blocked; Deactivated; , KBA , LOD-LE-OPP , Opportunity processing , LOD-LE-CQP , Customer Quote Processing , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions