Symptom
Error message "User <current user > CBXXXXXXXX01* (Employee Responsible) is not a Business partner" is raised when creating a Solution Order.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Open the App Manage Solution Orders.
- Click Create.
- Enter a Description.
- Enter a Sold-to party.
- Press Enter.
- The below error message is raised:
"User <current user > CBXXXXXXXX01* (Employee Responsible) is not a business partner" - When selecting the employee from the search help the following message is raised:
"Partner <employee name> (Employee Responsible) is neither an employee nor an organizational unit".
*Example figure used to denote the ID of the affected master data record.
Cause
The issue is caused by a missing mapping link between the selected Business Partner and the Employee or when entering a CB user instead of a Business Partner number in the 'Employee Responsible' field.
Resolution
- Use Business Partner number, and remove the CB from the beginning.
- Please ensure that the Master data has been maintained correctly in S/4HANA Cloud.
- For more information please refer to 2646803 - How to Maintain Workforce Person Data in SAP S/4HANA Cloud
Keywords
Business Partner, (Employee Responsible) is not a business partner, sold to, sold, sold-to, bp, employee, business, partner, person, is neither an employee nor an organizational unit, Partner <employee name> (Employee Responsible) is neither an employee nor an organizational unit, partner, employee, employee responsible, organizational unit , service , hr , , KBA , CRM-S4-SRV-SVO , S4CRM: Service Order , CA-WFD-INT , S/4HANA Cloud Workforce Domain Integration , LO-MD-BP , Business Partners , CRM-S4-SRV-SVO-2CL , S4CRM: Service Order (Public Cloud) , Problem