Symptom
- The user is getting synced in IAS with the username of their inactive employment record.
- The user is a concurrent employment and cannot log in to the SuccessFactors instance as their username is not correctly synced in IAS.
Environment
- SAP SuccessFactors HCM Suite
- SAP Cloud Identity Services – Identity Authentication IAS
Cause
The user is set as LoginName under Manage Login account in SF. Since the user has multiple employments, IPS will always pick the username which is set as login Name under Admin Center -> Manage Login Account.
Resolution
To address this:
- Go to Admin Center > Manage Login Accounts,
- Ensure that the Login name/username maintained in there is only the current active one.
Question: I have 1k+ user with the wrong LoginName set under Manage Login account in SF it is possible to bulk update the LoginName value for these users?
-> No. Currently, there is no out of the box way to bulk update LoginName. This has to be done manually.
See Also
Keywords
IPS, SYNC, loginname, manage login account, IPS sync, inactive record, inactive user, inactive, Active users, Active, LoginName already Exists , INC5311699 , KBA , LOD-SF-PLT-IAS , Identity Authentication Services (IAS) With BizX , Problem