Symptom
You recently upgraded your Analysis for Office from a version 2.7 or lower to Analysis for Office 2.8 or higher.
You open a saved workbook and you are not able to connect to your system.
Analysis for Office display the error below that is the same that you can see in the LOG file:
RETURN CODE: -102
Details: Com.Sap.Cof.Interfaces.Connection.Connection Exception:
ERROR service 'xxxxx' unknown
TIME Wed Feb 15 18:05:20 2023
RELEASE 785
COMPONENT NI (network interface)
VERSION 40
RC -3
MODULE D:/depot/bas/785_COR/src/base/ni/ninti.c
LINE 939
DETAIL NiPGetServByName: 'xxxxx' not found
SYSTEM CALL getaddrinfo
COUNTER 1
RETURN CODE: -102 —> SAP.Middleware.Connector.RfcCommunicationException:
ERROR service 'xxxxx' unknown
Environment
Analysis for Office 2.8 and higher
Reproducing the Issue
- Upgrade your Analysis for Office from 2.7 or lower to Analysis for Office 2.8 and higher;
- Open a saved workbook within Analysis for Office upgraded;
- Get the connection error.
Cause
Analysis for Office connection info saved with AO 2.7 is not recognized by AO 2.8 or higher anymore due to changes in the connection mechanism.
Resolution
To refresh the connection information you need to follow the steps below:
- Open your Analysis for Office
- Go to file > analysis > customize analysis > technical configuration
- Search for ForceRefreshConnectionInfo to true (check the box)
- Restart your Analysis for Office and reopen the workbook
Please check the following KBA with general information of usage of this parameter.
3254719 General information about the usage of parameter ForceRefreshConnectionInfo
See Also
Keywords
Connection, upgrade, ForceRefreshConnectionInfo, service, unknown, NiPGetServByName,not found, refresh, reload , KBA , BI-RA-AO-XLA , Excel Addin , How To