SAP Knowledge Base Article - Public

3306629 - Why Are C4C Customer External IDs Not Created Sequentially?

Symptom

When a C4C user creates a new customer to replicate to SAP ERP, the External ID that C4C generates for the customer is not consecutive.

Environment

  • SAP Cloud for Customer

Cause

The C4C object Accounts, like many other areas, uses a standard Number Range object to get the numbers for IDs.

Every application server buffers a batch of 10 numbers. So, depending on which application server the request was processed, it used the existing buffer or if nothing is buffered so far, it had to fetch the next batch. This might create gaps when multiple application servers are used, even to the fact that a lower number is used after a higher number.

Resolution

Changes to this behaviour will not be done unless there is a legal case which then has to be checked by the respective Product Management.

The current behavior is a compromise between compliance (a number is used once) and performance (order of numbers not sequential and possible gaps).

See Also

See following document for background information: How the Number Range Buffer Works

Keywords

EXTERNAL ID GAP SEQUENTIAL BUFFER , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , AP-RC-NR , Number Ranges (SAP Business ByDesign) , How To

Product

SAP Cloud for Customer core applications 2302