SAP Knowledge Base Article - Public

3306637 - Error message for Primary Email appears when completing Rehire (ROOE) - Onboarding

Symptom

Error “Only one record can be set as primary record for Email.” appears when completing ROOE, user is not able to continue.

Environment

SAP SuccessFactors Onboarding

Reproducing the Issue

  1. Login in instance
  2. Proxy as affected user
  3. In To-do dropdown option, click on “Perform Rehire Verification”
  4. Click on Start for a candidate
  5. Select Rehire on Event Reason to continue
  6. When click again in continue, error “Only one record can be set as primary record for Email.” appears.

Cause

Missing RBP permissions

Resolution

Grant permissions for affected user:

  • User Permissions - Employee Data - HR Information: Email and Business Email (View and edit). 
  • Make sure that Target Population is also set for all Employees / All External Users

Keywords

Only one record can be set as primary record for Email, primary, email, rehire, error, message , KBA , LOD-SF-OBX-RHM , Rehire Mechanism , Problem

Product

SAP SuccessFactors Onboarding all versions