Symptom
Error “Only one record can be set as primary record for Email.” appears when completing ROOE, user is not able to continue.
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Login in instance
- Proxy as affected user
- In To-do dropdown option, click on “Perform Rehire Verification”
- Click on Start for a candidate
- Select Rehire on Event Reason to continue
- When click again in continue, error “Only one record can be set as primary record for Email.” appears.
Cause
Missing RBP permissions
Resolution
Grant permissions for affected user:
- User Permissions - Employee Data - HR Information: Email and Business Email (View and edit).
- Make sure that Target Population is also set for all Employees / All External Users
Keywords
Only one record can be set as primary record for Email, primary, email, rehire, error, message , KBA , LOD-SF-OBX-RHM , Rehire Mechanism , Problem
Product
SAP SuccessFactors Onboarding all versions