Symptom
You have created the Renewal Agreement for the Customer Contracts in the system. But unexpected end date has been determined in the automatically Renewed Customer Contract.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to Sales Orders Work Center - Contracts View
- Open Contract ABC (where ABC stands for the Customer Contract ID)
- Navigate to General tab
- You can see Contract End Date is 02/28/2024 instead of 02/29/2024.
- Go to Business Configuration Work Center
- Open "Renewal and Cancellation for Customer Contracts" activity
- Select Renewal Agreement X (where X stands for the Renewal Agreement ID), you can see Renewal Duration is 1 year
- In Contract ABC, the Contract Start Date is 03/01/2023. Since 2024 is a leap year, so the expected Contract End Date should be 02/29/2024.
Cause
The Contract End Date of the renewed contract will not be set from the 28th to the 29th of February as the normal date calculation that occurs takes the renewal duration of 1 Year and directly adds 1 to the year of 2023. There is no check / calculation to be done to bring to "end of month".
The reason for this is that the original contract has an end date set as 28/02/2023. There is no indicator in the renewal rules to say "end of month", so when you renew for the year the system expects the same date the next year.
This in turn is why there is an influence on the invoice schedule as the item end date is set the same as header end date -> 28/02/2024.
Additionally, for renewed contracts into a leap year if you update the header contract end date , this updates the item level. You can then update the invoice schedule occurrence end date to the 29th for the leap year.
Resolution
The current behaviour is actually system design and there is no bug here.
We cannot change this as this would put other functions at risk of change. However, if you feel an enhancement should be added here please raise this on the influence portal.
Keywords
Customer Contract, Renew, Renewal Agreement, Leap Year, February, End Date , KBA , AP-CCP-CC , Customer Contract , Problem