SAP Knowledge Base Article - Public

3307049 - Error "Employee inconsistent; data for employee type missing" when replicating partner contact from CRM.

Symptom

 Error "Employee inconsistent; data for employee type missing" when replicating partner contact from CRM.

Environment

SAP Cloud for Customer

CRM

Reproducing the Issue

  1. Log into Cloud for Customer tenant.
  2. Navigate to the administrator work centre > general settings > web message monitor.
  3. Look for the failed message incoming from CRM with the following error on the BusinessPartnerReplicationIn interface:

    "Employee inconsistent; data for employee type missing"

    "A new employee needs at least one employment"

Cause

The business partner has 2 roles one as an Employee and one as a Contact Person.

The business partner replication interface is able to CREATE an employee assuming that the employee replication will come a bit later and update the employee related data. In this case the referenced business partner is already an (external) employee. Hence, it would be an UPDATE (role enhancement) of an existing employee which isn't supported by the business partner service. This has to be done using the employee service.

Resolution

You need 2 interfaces for this scenario as the Business Partner in this case is not just an employee. So the other roles are maintained by the Business Partner interface while the Employee roles are maintained by the employee interface.

In general you can't add the employee roles via the Business Partner projection, you can only add them via the employee projection (they are added implicitly if an internal or external employee type gets added).

Keywords

Cloud for Customer, Business Partner, Employee, Replication, BusinessPartnerReplicationIn, inconsistent, CRM. , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions