Symptom
After adding an attachment in the Work Permit portlet through People Profile and triggering a workflow, the attachment is not saved in the profile once the workflow is approved.
Environment
SAP SuccessFactors Employee Central
Reproducing the Issue
- Go to the profile of a user and click to edit the Work Permit Information portlet
- Edit the data and add an attachment
- Save the changes and see the workflow pop-up
- Proxy as the workflow approver and see that the attachment is available in the workflow request
- Approve the workflow
- Go back to the profile of the edited user and see that the attachment is not displayed.
Note: issue does not happen when the option "Enable Centralized Services for Work Permit to save changes on Editing UI" is disabled in Company System and Logo Settings.
Cause
This issue occurs because the field attachment-id is not configured in the HRIS Element workPermitInfo. When this field is not configured, the system treats it as UI enabled by default and it is possible to add it while editing the data.
Resolution
Configure the attachment-id field for Work Permit Information by following the steps:
- Go to Manage Business Configuration
- In Employee Central, go to "workPermitInfo"
- In HRIS Fields, add a new field with the ID "attachment-ID"
- Put a label to the new field, select it as enabled and save.
After making this change, the attachments will be saved after approving work permit workflows.
See Also
Keywords
work permit, attachment, not saved, workflow, work permit workflow, attachment-id, document, missing attachment, people profile, INC3970858 , KBA , LOD-SF-EC-PER-WRK , Work Permit - Config, Rules, RBP, UI , LOD-SF-EC-WFL , Workflows - Configuration, Tools, Objects & Rules , Problem