SAP Knowledge Base Article - Public

3307245 - An Obsolete Contact is not Removed From the Registered Product

Symptom

Once the contact is set as obsolete, it is not automatically removed from an existing registered product.

Environment

 SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Installed Base work center.
  2. Go to the Registered Product view.
  3. Click on a new button to create the new registered product.
  4. In the new registered product screen enter the customer as XYZ(where XYZ represent the customer name), which has contact as XYZ1(where XYZ1 represent active main contact of account XYZ).
  5. Enter other mandatory fields and save to create new registered product LMN (where LMN represent the newly created registered product).
  6. Go to the Customer work center.
  7. Go to the Contact view .
  8. Search and open the contact XYZ1 and set it as Obsolete.
  9. Go back to registered product LMN.
  10. You will see the obsolete contact XYZ1 is not automatically removed from existing registered product LMN.

Cause

Since the registered product was created when contact XYZ1 was active, further making the changes in contact master data i.e. setting it as obsolete will not automatically remove this contact XYZ1 from existing registered product LMN.

Resolution

This is an expected system behavior.

Keywords

 Registered Product , Contact , Obsolete , Active , KBA , obsolete contact , existing registered product , LOD-LE-IBA-IBA , Installed Base , LOD-LE-IBA-IPO , Installation Point , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions