SAP Knowledge Base Article - Public

3307661 - Custom business object is not available/visible for selection when creating a new workflow rule

Symptom

You observe that your custom business object created from SAP Cloud Applications Studio is missing for selection when creating a new workflow rule.

Environment

  • SAP Cloud Applications Studio
  • SAP Cloud for Customer

Reproducing the Issue

  1. Go to Administrator work center.
  2. Go to Workflow Rules work center view.
  3. Click on new button.
  4. Observe that the affected custom BO is missing.

As a pre-requisite, you have:

  • Created a custom business object.
  • Created notification rules for the custom BO.
  • Scoped the custom solution in the implementation project.

Cause

Cause 1: You have a change project in your tenant which is already merged but has not been activated.

Cause 2: Your implementation project is not a change project.

Resolution

Resolution for cause 1: In order to turn this change project active, execute the activity "Activate Solution Capabilities" in the implementation projects view from the business configuration work center.

Resolution for cause 2: Open the implementation project to allow the upgrade to update the project scoping.

See Also

SAP help documentation to create notification rules: Enable Notification Rules

Keywords

PDI, SDK, Studio, workflow, rule, WKF, custom, business, object, missing, not, available, visible, visibility, create, drop, down, list, values , KBA , LOD-CRM-WKF , Workflow , How To

Product

SAP Cloud Applications Studio all versions ; SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions