SAP Knowledge Base Article - Public

3307737 - Cannot See Full E-mail Body In Ticket Timeline

Symptom

You are not able to see full E-mail body in Timeline view but the full E-mail is available in the List view.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to Service Work Centre
  2. Go to Tickets view
  3. Open any E-mail Ticket 
  4. Go to Timeline facet
  5. In the Timeline view , notice the E-mail body is not complete and also the "See More" option is not available
  6. Switch to List view on Timeline facet and see the E-mail body does display the complete E-mail body text

Cause

This occurs because of the way the email's mime body content is structured, specifically when we check the height box. By default, our system uses different controls to display data in different views (e.g List View, Email Activity, etc). The Timeline main view, specifically view uses an iframe that cannot read Mime Emails that utilize "div" tags with a height set to "100%.

The `<div>` element is an HTML tag used to define a division or a section in an HTML document. It is a container that allows you to group and organize other HTML elements within it. 
In Overall, the `<div>` element in the provided email MIME content is used as a container to group and style the content within it.

Resolution

This is the current system behavior of the Timeline view. It's important to note that these types of emails are uncommon and typically associated with specific customer email providers that use different div tags compared to industry standards.

For these specific emails, you can use the List view to read the full content of the email or open the Email activity that originated it and review the Message table.

Keywords

Ticket , Timeline view , Complete Email , Full Email , Timeline , See more , KBA , LOD-CRM-SRP-INT , Ticket Interactions , LOD-CRM-SRP , Service Request Processing , How To

Product

SAP Cloud for Customer core applications 2302