Symptom
Customers want to know if upsert for the field Event Reason via integration center does follow RBP.
Integration user is not having permission for one event reason and on the UI integration center user is not able see the event reason when trying to insert new record.
- Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
- SAP SuccessFactors HXM Suite
- Integrations
- Integration Center
- Integrations
Reproducing the Issue
- Navigate to integration center open integration center job.
- Try to upsert event reason data using EmpJob starting entity.
- Upserted successfully
- But on when we try to create new record through UI "Insert new Record", Event Reason is not present in the drop down.
Cause
That is the expected behavior. Users have permission Employee Central Foundation OData API
Resolution
Upserting in EmpJob entity will only check the write permission on EmpJob. It will not check related Event Reason permission.
On UI, you will be blocked when choosing an event reason, because the dropdown list is actually querying(reading) event reasons, that read operation will check event reason permission.
See Also
Event reason, Integration center, permission, OData, Foundation object, RBP, Permission, Insert new Record, UI
Keywords
KBA , LOD-SF-INT-INC , Integration Center , LOD-SF-INT-INC-JOB , Integration Center Job , Problem