Symptom
The outbound deliveries are cancelled or zero-out at EWM side, but the status at LE side is not updated.
There are stuck queues at Warehouse Monitor -> Tools Node -> Message Queue.
Error message VL 198
Item &1: Only &2 ST from material &3 are available
Environment
SAP S/4HANA Cloud System
Reproducing the Issue
- Go to APP Warehouse Monitor -> Tools Node -> Message Queue.
- Stuck queues are found with error message.
- Go to APP Display Outbound Delivery, the goods movement status is still "A".
Cause
ATP check is activated for EWM relevant Outbound Deliveries.
Regarding EWM having a concept for physical stock and available stock, it is not necessary to activate the ATP check for EWM-relevant deliveries.
Resolution
There are several options to reprocess the stuck queues at Warehouse Monitor:
- Adjust the ATP stock and make sure the stock is enough before processing the stuck queues.
- If all of the storage locations are EWM managed, you may consider switching off the ATP check at the Item level. Please go to customizing Define Delivery Item Categories (SSCUI 102974), select the item category at the outbound delivery, and change the field "Do Not Check Availability" to "X". Save the customizing and reprocess the stuck queues.
- Or if the storage locations are managed with IM and EWM. The IM-relevant outbound deliveries can be impacted if deactivating the ATP check is like option 2. You can consider switching off the ATP from a material level. Go to APP Change Material -> Tab MRP 3 -> field Availability check, change the field as NC then reprocess the stuck queues.
See Also
Keywords
VL 198, EWM, Outbound Delivery, Stuck Queue, Availability Check, Hanging Queue, Position, LO-SPM-OUT , KBA , LO-SPM-OUT-2CL , Outbound Process (Public Cloud) , CA-ATP-2CL , Available to Promise (ATP) (Public Cloud) , Problem