SAP Knowledge Base Article - Public

3309097 - Payment Batch Approval Locked, cannot unlock - SAP S/4HANA Cloud Public Edition

Symptom

  • Error message in the App "Approve Bank Payments". ERROR : Failed to submit batch. It is locked by another user.
  • Payment batch status is stuck with the In Approval status after the final approval step.

Environment

SAP S/4HANA Cloud Public Edition

Reproducing the Issue

  1. Payment batch is in the Final Payment Approval step.
  2. Go to App Approve Bank Payments.
  3. Select the payment batch and press approve button.
  4. Next select the submit button for the payment batch.
  5. Notice the error.
  6. Go to Monitor payments app to find the payment batch is still stuck with the In Approval status.

Cause

The issue with Lock is not the correct one, the issue probably happens during Submit part of the process due to various reasons. It is not possible to state one exact reason why the payment batch remains In Approval status after the Submit action. After the unsuccessful Submit the draft stays open and the Payment Batch cannot be approved anymore.

Resolution

Enable the Monitor Payments app to be able to fix the payment batches.

  1. Configure the customizing activity SSCUI (106107) "Fix Errors for Payment Batches".
  2. Use these settings to enable several functionalities:
    Correct mismatch of statuses.
    Set payment batches to status "Automatically Rejected" (IBC20).
    Mass reset and reverse of payment documents within payment batch items.
    Add missing approvers to payment batches.
    Retry payment medium creation

See Also

F0673A, Lock, by, another, user, submit, approve, approve and submit, failed to submit batch. It is locked by another user, In approval, IBC20, IBC02, IBC15, approve bank payments, final approval step. final approver

Keywords

KBA , FIN-FSCM-BNK-2CL , Direct Bank Communication (Public Cloud) , Problem

Product

SAP S/4HANA Cloud Public Edition all versions