Symptom
When adding tables in SAC add-in for Microsoft Office, the default name ranges generated by the product are SACTable1, SACTable2, etc.
After changing the default name range via Name Manager, the table does not work anymore and the error below occurs mentioning that the specific name range does not exist:
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NamedItemNotExistingError: SACTable1 doesn't exist any more.
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Environment
SAP Analytics Cloud, add-in for Microsoft Office
Reproducing the Issue
- Add a table in SAC add-in for Office;
- Change the name range via Name Manager;
- Try to refresh or do any change in the table;
- Confirm the error "NamedItemNotExistingError: SACTable1 doesn't exist any more." in the builder panel.
Cause
This is not a bug in the tool. The name ranges generated by the product should not be changed.
Resolution
Change the name range of the table back to the original name, which is mentioned in the error message (e.g. SACTable1).
Keywords
name range, name manager, tables , KBA , LOD-ANA-OF , SAP Analytics Cloud, add-in for Microsoft Office , Problem