Symptom
When attempting to retrieve a single object per id, it throws the error 404 not found.
Environment
- SAP Analytics Cloud 2023.5.0
- Postman
Reproducing the Issue
- Make a request to the token URL and retrieve the access token.
- Make a GET request to <SAC-Tenant>/api/v1/scim/Groups/<id>
- Observe the error in the symptom.
Cause
The group was created via the user interface and cannot be retrieved via the API by id.
Resolution
- Create the Group via a POST request and then retrieve via a GET request.
- Include the following in the headers: Authorization - Bearer <access-token>, x-sap-sac-custom-auth - true
- On your SAC tenant, navigate to System -> Administration and stay on the first tab System Configuration.
- Search for "Ignore Content Namespace For Teams" and switch this toggle from off to on.
See Also
2569847 - Where can you find SAC user assistance (help) to use, configure, and operate it more effectively?
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2487011 - What information do I need to provide when opening a case for SAP Analytics Cloud?
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Keywords
KBA , LOD-ANA-ADM , SAC Administration , Problem