Symptom
When my users login via SSO, they are unassigned from the user groups I manually assigned them to.
Environment
SAP Signavio Process Manager or Collaboration Hub
Reproducing the Issue
- Click on your SSO link.
- Once logged in, navigate to Explorer.
- Click 'Setup'.
- From the dropdown, select the Manage users & access rights.
- Click on the User group tab
- Click on the group you should be assigned too.
- You see that you are not included in the list of users.
Cause
The SAML response that the IdP is sending to Signavio includes user groups the users should be assigned to.
Each time the user logs in via SSO, the users' groups are being replaced.
Resolution
Include all the groups for your user in the IdP user groups attribute.
See Also
For more information on user groups in SAML, please read the following excerpt from our user guide: Single Sign-on Using SAML > Configure your IdP | SAP Help Portal
Keywords
process, manager, user, group, saml, sso, link, assign, manual, over, written, un, assign, signavio_groups_v1, signavio_groups_v1_azure , KBA , BPI-SIG-CA-SEC , Workspace Security for SAP Signavio Transformation Suite , Problem