SAP Knowledge Base Article - Public

3310219 - Automating the redetermination of parties in tickets

Symptom

  • Goal: Automate Service & Support team redetermination for tickets.
  • Plan: Use SDK to add "Redetermine keeping manual changes" or "Redetermine Completely" actions based on the case.
  • Issue: Unable to select related action via SDK as it doesn't exist.

Environment

  • SAP Cloud for Customer
  • SAP Cloud for Service

Cause

  • Working as designed
  • Not a product defect
  • Redetermine Completely action cannot be released for custom usage in PDI (SDK)
  • Action is highly performance intensive
  • Action can have significant functional impacts
  • Potential for severe unwanted side effects if released for consumption in PDI
  • The solution provided in KBA 2920664, is not possible in this scenario, since there is different code logic in place, and said that option is not available for the above scenarios

Resolution

  • User should continue to perform the re-determinations manually
  • The design was to give the business user the flexibility to decide whether or not parties need to be re-determined.

See Also

  • 3139441 - Territory Not Redetermined Based on Ticket Routing Rules
  • 2920664 - Manually Changing a Party Role Does Not Trigger The Automatic Re-Determination in Ticket Involved Parties
  • 2438900 - Ticket Routing Rule Does Not Work When The Team Or Processor Is Changed Manually

Keywords

Automated re-determination, PDI, , KBA , LOD-CRM-SRP , Service Request Processing , Problem

Product

SAP Cloud for Customer core applications 2302