SAP Knowledge Base Article - Public

3310358 - Mails going into spam even with DKIM

Symptom

Mails are going into the spam folder although the header contains a valid DKIM signature

Environment

SAP Business ByDesign

Cause

IP's are not whitelisted

Resolution

Please contact your IT Department to set IP's allowed:

  • Listing for receiving E-Mails in your Infrastructure and
  • SPF records that you created in your own DNS and
  • any throttling on your e-Mail server based on IP address,
  • Whitelisting / Authentication based on e-mail headers like “Return-Path” / “Envelope-Sender” / “mailfrom” / “Bounce Address

See below:

  • Business E-Mails are relayed from ByDesign (SAP Network) – Cronus (Hosted in SAP Network) – AWS (Hosted in Internet) – Recipients.
  • Business E-Mails will be enabled with SPF policy by default.
  • Business E-Mails are sent through these IP ranges/addresses 199.255.192.0/22, 199.127.232.0/22, 54.240.0.0/18, 69.169.224.0/20, 23.249.208.0/20, 23.251.224.0/19, 76.223.176.0/20, 54.240.64.0/19, 54.240.96.0/19, 52.82.172.0/22.
  • SPF records for the business mails are updated on the technical From/Mail From/Envelop-From address, which is always dsn@myXXXXXX.mail.sapbydesign.com or dsn@myXXXXXX.mail.sapbyd.cn. Example: SPF record for domain: myXXXXXX.mail.sapbydesign.com or myXXXXXX.mail.sapbyd.cn would look be like: “v=spf1 include:_spf.cmail.ondemand.com include:amazonses.com ~all“

See Also

Blog: Next-Generation Cloud Delivery transition – New Business ByDesign E-mail Infrastructure

Keywords

Spam Folder, DKIM, Emails going into Spam, White List, IP address , KBA , AP-RC-OUT , Output Management , How To

Product

SAP Business ByDesign all versions