Symptom
In app Manage Automatic Payments (app ID F0770), tab Output Items for Payment Advice, channel Email
The following errors are shown in log:
..
No data supplied to render email template "FFO_PAYM_ADVICE_EMAIL_TEMPLATE"
Processing of item & with technical ID & using channel EMAIL Failed.
"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."
Environment
SAP S/4HANA Cloud
Reproducing the Issue
- Create Payment using app Manage Automatic Payments
- Approve Payment Batch in app Approve Bank Payments ( App ID F0673A)
Cause
In CE2302, SAP deliver one new feature of email template FFO_PAYM_ADVICE_EMAIL_TEMPLATE.
One CDS view I_PAYMENTPROPOSALPAYMENT is binding to this email template. Based on this changes, the variant can be used in email functionality.
For Authorization to fetch CDS view data when generate email, assignment to Business catalog SAP_FIN_BC_BCM_PAYM_DISP_PC is required
Resolution
Add Business catalog SAP_FIN_BC_BCM_PAYM_DISP_PC to final approval user role
See Also
Keywords
BCM, SAP_FIN_BC_BCM_PAYM_DISP_PC, email output request, failed status, final approval, Remittance , KBA , FI-FIO-AP-2CL , Fiori UI for Accounts Payable (Public Cloud) , Problem