Symptom
Some information are not being populated when triggering a custom e-mail notification.
Environment
SAP SuccessFactors Employee Central
Reproducing the Issue
- E-mail template has been configured according to the documentation: Setting Up Custom Workflow Notifications | SAP Help Portal;
- A custom e-mail is triggered;
- Some information is not populated.
Cause
The fields that were not populated have effective dates in the future. Therefore, system is not designed to populate this fields.
Resolution
This is expected behavior.
System will populate the template with the information that is currently available in Employee Profile at the moment the notification is being triggered. Data that will become effective in the future will not be considered.
See Also
Keywords
hire, future, future hire, mapping, document, generation, document generation, document generation mapping, manage document template, template, manage document generation template, workflow, , notification, trigger, triggered, workflow notification, custom e-mail notification, e-mail, email, employee central , KBA , LOD-SF-EC-WFL-CUS , Custom Workflow Notifications , LOD-SF-EC-DOC , Document Generation , How To
SAP Knowledge Base Article - Public