Symptom
Error message in SoapUI response when trying to ADDORUPDATE languages that contain special characters as separator or in the name via SimpleProductAdministration and ImportMaterialsFromERP API:
"Server was unable to process request. ---> '/' is an unexpected token. The expected token is '>'."
Environment
SAP SALES CLOUD CPQ
Reproducing the Issue
1. Open SoapUI;
2. Create a request for SimpleProductAdministration or ImportMaterialsFromERP API;
3. Input the ADDORUPDATE in the node <web:action>;
5. Create the node for product and product name;
6. Input the name of product in USEnglish node;
7. Create a second node with any language that has special characters in the name or as separator and add the translation;
8. Run the API.
Example:
<web:action>ADDORUPDATE</web:action>
<web:xDoc>
<Products>
<Product>
<ProductName>
<USEnglish>ProductName</USEnglish>
<Français/French>Translation</Français/French>
</ProductName>
</Product>
</Products>
</web:xDoc>
Cause
Limitation for translations via SimpleProductAdministration and ImportMaterialsFromERP API when using special characters in dictionary name. As example "/".
Resolution
Dictionary systemID should be used instead of dictionary name.
Keywords
SimpleProductAdminstration, ImportMaterialsFromERP, SOAP API, Limitation, translations, CPQ , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , Known Error