Symptom
Sent E-mails are landing in SPAM folder even after successful DKIM activation.
Environment
SAP Business ByDesign
Reproducing the Issue
Example: Purchase order Emails
- Go to Purchase order workcenter view.
- Select Order ID.
- Click edit.
- Click View All.
- Open Output history.
E-mails sent successfully by sender however E-mails are landing in SPAM folder.
Cause
Business E-Mails are relayed from ByDesign (SAP Network) –> Cronus (Hosted in SAP Network) –> AWS (Hosted in Internet) –> Recipients
Resolution
- Business E-Mails will be enabled with SPF policy by default. Check SPF records in your own DNS or any throttling on user e-mail server based on IP address, whitelisting / Authentication based on e-mail headers like “Return-Path” / “Envelope-Sender” / “mailfrom” / “Bounce Address”.
- Business E-Mails are sent through IP range/address. Set IP and allow listing for receiving E-Mails in your Infrastructure.Refer KBA - 2570539
- Always dsn@myXXXXXX.mail.sapbydesign.com or dsn@myXXXXXX.mail.sapbyd.cn. Example: SPF record for domain: myXXXXXX.mail.sapbydesign.com or myXXXXXX.mail.sapbyd.cn would look like: “v=spf1 include:_spf.cmail.ondemand.com include:amazonses.com ~all“
See Also
KBA : 2570539 - IP Address for SAP Business ByDesign Data Centers
KBA : 2829404 - How to check the IP Range of the tenant based on Data Center in ByD and C4C
Blog : Next-Generation Cloud Delivery transition – New Business ByDesign E-mail Infrastructure
Keywords
IP whitelisting, Emails landing in SPAM,SPF ,IP range,DKIM Activation , KBA , dkim activation , spf , ip range , ip whitelisting , emails landing in spam , AP-RC-OUT , Output Management , Problem