SAP Knowledge Base Article - Public

3311984 - [Onboarding] - Tokens are not populating in Email notifications triggered for new hire task

Symptom

  • Email tokens configured in email template body are not populating when the email notification is triggered.
  • Issue with some users not all

Environment

SAP SuccessFactors Onboarding

Cause

  • This behavior is observed whenever New hire data review step is skipped and the jobInfo fields/the fields used for tokens are not mapped from RCM.
  • The fields appear updated from Access New Hire Data link due to execution of the onChange rule configured on position field, but the values are not saved to Database. 

Resolution

  • If New hire data review step is not configured and Personal data collection step is triggered along with New hire task, then please complete the personal data collection step so that the Token field value is saved in Database.
  • Post completion of PDC step complete the New hire task and the email triggered will have tokens populated correctly. 

Keywords

Tokens, New hire task, email notification, email services, blank token, Onboarding , KBA , LOD-SF-OBX-EML , Notifications , Problem

Product

SAP SuccessFactors Onboarding 2211