Symptom
You have a Cloud Platform Integration (CPI) iflow connected with SuccessFactors (SF) Integration Center (IC) with or without Intelligent Services Center (ISC) flow
and you realise that in case its failing, it is triggered multiple times in CPI and the error code is HTTP 429, 500, 503 or HTTP 504
Environment
- SAP SuccessFactors HXM Suite
- Integration Center
- Intelligent Services Center
- Cloud Platform Integration
Reproducing the Issue
Open your CPI environment and you see multiple iflows triggered for failed iflows. The iflow is triggered from SF IC job.
Cause
In IC there is a re-try mechanism as per guide described here
Resolution
Please always check the SF audit logs for the valid error in SF audit log settings. You might see other error status in other tools however the retry mechanism works based on the HTTP code received by SF system and its available under SF audit log settings.
Further information regarding the retry mechanism:
- Is it configurable how many retry can be done? or is it design by system? - How often will the system do the retry? twice?
- Retry details are non-configurable. The system will attempt a retry once after the first unsuccessful call. So in total there will be two calls to the endpoint from IC side in case of failure(specific error codes)
- Retry details are non-configurable. The system will attempt a retry once after the first unsuccessful call. So in total there will be two calls to the endpoint from IC side in case of failure(specific error codes)
- Will it retry directly after the first attempt fails? or is there any waiting period?
- We do have RedeliveryDelay i.e. fixed delay in milliseconds between each redelivery attempt which is 10000(10 sec) in our case.
See Also
Using the integration Center guide link
Keywords
IC job failure, CPI iflow trigger twice or multiple times, retry mechanism, Integration, Center, Centre, HTTP, 429, 502, 503, 504 , KBA , LOD-SF-INT-INC-ISE , Integration Center from ISC Events , LOD-SF-INT , Integrations , Problem