SAP Knowledge Base Article - Public

3312258 - Contact Information (Phone Number, E-mail Address) Not Removed From Employee Profile Header When Removed From 'Contact Information' Portlet

Symptom

When the phone number or e-mail address of an employee is removed from the 'Contact Information' portlet, this is not synced to the employee profile header, so the header still shows the e-mail address or phone number

Environment

SAP SuccessFactors HXM Suite

Reproducing the Issue

  1. Go to an employee's profile
  2. Go to the 'Contact Information' portlet
  3. Remove the employee's 'phone number' or 'e-mail address' value(s) (the primary value, e.g. business e-mail / business e-mail, if using hard-coded mappings) and save the change
  4. Refresh the page - the information is not removed from the employee profile header, even after a HRIS Sync

Cause

This is a current expected behaviour as removing information and not replacing it with another value does not cause a trigger from EP to the UDF, so the UDF retains the previous value. As the employee profile header takes its values from the UDF, the old values still show.

Resolution

In order to remove the values from the employee profile header, a Basic User import should be run for the employees in question, removing the unneeded value (phone number, e-mail address) from its respective column so no value is retained for the employee. Once the import is done, the value should be removed on the employee's profile header.

Keywords

contact information, phone, email, e-mail, header, employee profile, employee profile header , KBA , LOD-SF-EP-HED , People Profile Header Ribbon , How To

Product

SAP SuccessFactors Employee Central all versions