Symptom
User notices that all obsolete customers are not picked up for automatic deletion.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Navigate to Data Protection and Privacy workcenter view.
- Go to Common Tasks view.
- Click "Administer Obsolete Business Partner Removal Runs"
All obsolete customers are not picked up for automatic deletion.
Cause
This is system expected behaviour.
The current implementation of the obsolete customers removal run picks private accounts of role "individual customer" for automatic deletion.
Resolution
Customers of other roles (Prospect etc.) does not get picked up for automatic deletion.
Follow below steps to check assigned role for particular customer which is not picked up for automatic deletion,
- Navigate to Data protection and privacy workcenter
- Go to Personal Data removal workcenter view
- Open All private accounts default list
- Search for the customer.
- Open Customer ID. At top of the screen user can check if selected customer ID is an individual customer/Prospect etc.
Customer can be individually deleted from the personal data removal workcenter view.
Please follow below steps to delete customer individually,
- Navigate to Data protection and privacy workcenter
- Go to Personal Data removal workcenter view
- Open All private accounts default list
- Search for the customer and select Customer ID.
- Click Remove Data button
- Review the data and click delete.
Selected customer will be removed.
Keywords
Obsolete Customers, automatic deletion, removal run, private accounts, prospect, Administer Obsolete Business Partner Removal Runs , KBA , administer obsolete business partner rem , prospect , private accounts , removal run , automatic deletion , obsolete customers , AP-RC-ILM , ByD,C4C,Travel: Information Lifecycle Management , Problem